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Introduction 
 
This tutorial documents provides insight into the methods I use when processing 
my astronomical images.  The particular image being used in this tutorial is a 
widefield shot of the constellation Auriga using a 200mm telephoto lens. 
 
Procedure 
 
The following workflow diagram illustrates the steps necessary to capture and 
process this image: 
 
 

Light Frames

Dark Frames

Flat FramesLight Box

Astronomical
Target

Image
Calibration

Digital
Development

Gradient
Correction

Star
Minimization

Levels
Curves Adjust

Sharpening

Final Image

 
 

Workflow Diagram 



 
    ��������	
���
�
��������                                                                           

 
 

December 2006 Rev - - 2 - http://www.DanielMcCauley.com 
��������	
������

 
The first step is to calibrate the light frames using the support frames.  I use the 
Automatic Image Set Processing feature in ImagesPlus v2.80.  Run ImagesPlus 
and select from the main menu, File > Automatic Image Set Processing.  This 
tutorial assumes you will be using Canon .CR2 RAW files. 
 
Under the Process tab, set Image Set Process Type  to Mono, At Capture WB 
Bayer CFA. 
 

 
Set Image Set Process Type  to Mono, At Capture WB Bayer CFA 
 
Under the Light Frames tab, select the light frames to be calibrated. 
 

 
Selecting the light frames to be calibrated 
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Under the Dark Frames tab, select the dark frames to be used for calibration.  
Set Combine Using  to Avg. 
 

 
Selecting the dark frames for calibration and setting Combine Using  to Avg 
 
Under the Flat Frames tab, select the flat frames to be used for calibration.  Set 
Combine  Using to Wt Median. 
 

 
Selecting the flat frames for calibration and setting Combine Using  to Wt Median 
 
 
Under the Process tab, click on Light Frame Processing Parameters.  Check 
the Automatic Master Dark Frame Matching box , make sure RGB is selected 
under Bayer Conversion Output File Color Type . 
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Setting the Light Frame Processing Parameters 
 
When this is all done, click on the Process tab of the Automatic Image Set 
Processing window and click on Process.  This will begin the calibration process 
and will take several minutes to complete.  The final calibrated light frames will 
have the prefix BINT_.   
 
Next, the final calibrated BINT_ images will be aligned.  For this, I again used 
ImagesPlus.  Choose from the main menu, File > Image File Operations > 
Align Files > Translate, Scale, Rotate.  I used Alignment Method :  Centroid, 
and Alignment Type:  Translate, Rotate.  Please refer to the ImagesPlus 
manual and video tutorials for additional information on how to align images. 
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Setting the alignment parameters 
 
 
Next, the translated and rotated TnRt_BINT_ images will be combined (stacked).   
Choose from the ImagesPlus main menu, File > Image File Operations > 
Combine.  Set the Combination Method  to Min Max Excluded Average.  This 
will average the pixel values of all calibrated light frames together, but will discard 
the minimum and maximum pixel values. 
 

 
Setting the Combination Method  to Min Max Excluded Average 
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Under the File Control tab, click on Combine  to stack the images.   
 
Open up the combined image.  The default filename for this process is 
CombineFilesExcAvg.tif.  As you can see, the image is quite dark and this is 
because this is a linear image which hasn’t be stretched, so most of the detail is 
hidden in the shadow portion of the image.  The first thing we will need to do is 
stretch the image.  We will do this by using ImagesPlus Digital Development 
algorithm. 
 

 
Final calibrated and stacked image (linear TIFF) 

 
Choose from the main menu, Color > Brightness Levels and Curves > Digital 
Development. 
 
The easiest way to perform a Digital Development stretch is to simply click on the 
Auto  button.  It truly doesn’t get easier than that! 
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ImagesPlus Digital Development – Clicking on Auto 

 
The next step is also quite easy.  Move the Background  slider towards the right 
until the sky background becomes a slight gray. Move it just enough to bring out 
the faint detail.  The exact shade of gray isn’t critical, as you will be correcting 
this later when setting the black point of the image. 
 
Once this is done, click Done and then save your image.  Make sure to save as a 
16-bit TIFF file. 
 
Note that you could have also been more aggressive in the Digital Development 
routine by moving the Break-Point  slider towards the right, but I usually don’t do 
this as it does have a tendency to clip and oversaturate the stars. 
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Moving the Background  slider towards the right 

 
Again, if you haven’t already done so, save the image as a 16-bit TIFF file and 
exit ImagesPlus. 
 
Now the next step will involve in correcting the gradients present in the image.  If 
you carefully inspect the image on the next page, you’ll see there is some 
general vignetting in the image as well as red color cast in the corners and 
leftside of the image.  We will use the freeware program, PixInsightLE to correct 
these gradients. 
 
The first step is to run PixInsightLE and open up the image which was just 
stretched via the Digital Development algorithm in ImagesPlus. 
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Final stretched image after Digital Development 
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Opening up the image in PixInsightLE 

 
From the main tools palette, choose the Dynamic Background Extraction  tool.  
 
 

 
Choosing the Dynamic Background Extraction tool 
 
There are three basic parameters which need to be adjusted - the Default 
sample radius , the Auto intervals (horizontal) , and the Tolerance.  These 
parameters are located under the Global tab of the Dynamic Background 
Extraction window as shown below.  The Default sample radius  and Auto 
intervals (horizontal)  set the size of the sample box and the number of sample 
boxes used in the image.  For my image, I chose values of 24 and 30 
respectively.  Depending on your image size,  you may need to adjust these 
accordingly. 
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Generating the sample grid using the Dynamic Background Extraction  tool 

 
The next parameter which must be adjusted is the Tolerance.   The Tolerance  
determines how sensitive the sampling is for each sample box.  I usually start out 
with a value of 0.5 as shown above. 
 
Click the Generate  button (below the Resize All  button), to generate a grid as 
shown above. 
 
Next, click on the Current Sample tab of the Dynamic Background Extraction 
window.  We will now inspect individual sample boxes to determine if the value 
for the Tolerance  is acceptable for this image. 
 
Click on any sample box in the image and inspect the black and white sample 
image in the Dynamic Background Extraction window.  The black and white 
sample image should show only the stars as black dots with none of the 
background showing.  If the background is showing, then decrease the 
Tolerance.   If only some of the stars are showing, then increase the Tolerance.   
The following two examples illustrate what a good and bad value for the 
Tolerance  looks like. 
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Tolerance = 0.5 (Good – stars show as black dots in sample image) 

 
Once the Tolerance value has been selected, the next step is to adjust the 
sample boxes.  Simply delete any sample boxes that are located on nebulous 
portions of the image.  Also, delete any sample boxes (or move) that contain very 
bright stars as this will negatively affect the background extraction algorithm.  By 
deleting these sample boxes, you remove that portion of the image from the 
background extraction algorithm.  To remove a sample box, simply click on it and 
then press the DELETE key on the keyboard. 
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Removing sample boxes that are located in nebulous regions of the image 

 
Now we are ready to extract our background.  Click on the Generate  button at 
the bottom of the Dynamic Background Extraction window to extract the 
background. 
 
After about a minute of calculation, a new window should appear which shows 
the extracted background.  This is shown in the image on the next page. 
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Extracted background image 

 
Next, we need to subtract this background image from our original image. 
 
From the main menu, choose Process > General > Pixel Math  and the Pixel 
Math window will be displayed as shown on the next page. 
 
Click on New and select Operator  as SUB: Subtract, and select Operand  as 
Image01_background as shown.  For Destination , click on the box which reads 
Create new image. 
 
Click on Apply. 
 
The Images for : Pixel Math window will be displayed.   
Select Image01: 3520x2346 and click OK. 
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Pixel Math Window – Selecting the operator and operand 
 
 

 
Selecting the image for Pixel Math 
 
After a few seconds, a new image will be displayed.  This will be the final 
processed image with the vignetting and color gradient removed. 
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Final gradient corrected image 

 
 
Save the file and exit the program – you are now done. 
 
The next step is to continue processing the image in Photoshop.  Run Photoshop 
and open up the image that was just saved in the previous step. 
 
I tend to like images with pinpoint stars as they more closely represent what is 
seen with the eye and also large bloated stars tends to distract the viewer from 
the more important objects in an image such as nebulae, star clusters, etc…  The 
first step in star minimization is to select the larger and brighter stars in the 
image.  From the main menu, choose Select > Color Range.  With the dialog 
window open, use the eyedropper tool and click on the center of one of the larger 
and brighter stars in the image as shown below.  Selection Preview  should be 
set to None so that the original image is displayed in the main viewing window.  
This will select the approximate color range of the brightest stars in the image. 
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Selecting the center of a bright star in the image 

 
Change the Selection Preview  to Black Matte.  This will display the actual 
selection mask.  Everything that is selected will appear white, and everything that 
is not will appear black.  Adjust the Fuzziness  slider until only the largest and 
brightest stars are selected. 
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Adjusting the Fuzziness  slider to select the largest and brightest stars 

 
Click OK when you are satisfied with the selection. 
 
Next, from the main menu, choose Select > Modify > Expand , and enter a value 
between 2 and 4 pixels in the Expand Selection dialog window.  For this 
particular example, I used a value of 2 pixels.  You will need to find the correct 
value by trial and error. 
 

 
Expanding the selection by 2 pixels 
 
The following image shows the expanded selection.  Notice that most of the 
largest stars are selected here and that the selection borders envelope the entire 
star with just a little space extra.  This is important.  If this is not the case, you will 
end up with halos around most of the stars after the minimization filter is applied. 
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Image with expanded selection 

 
The final step involves invoking the minimization filter to reduce the star sizes.  
From the main menu choose Filter > Other > Minimum. 
 
In the Minimum window dialog box, enter a value for Radius  of 1 pixel. 
 
Click OK. 
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Entering a value of 1 pixel for radius 
 
At this time, the minimization filter is applied to the image and the star sizes have 
been reduced.   
 

 
Image with star minimization applied using Photoshop 

 
The next step in my workflow is to set the black point of the image. 
 
Choose from the main menu, Image > Adjustments > Levels.  
 
On the bottom right of the Levels dialog window, double click on the Set Black 
Point eyedropper.  This will allow you to use the color picker to select a value for 
the black point. 
 
In the Color Picker dialog window, enter the values for RGB as 35,35,35 
respectively.  I tend to like the sky background to be a dark gray rather than 
black. 
 
Next, click on OK and return to the Levels dialog window.  With the Set Black 
Point  eyedropper still selected, move the eyedropper on the image, right click 
the mouse, and set the sample size to 5x5 Average.  This ensures that when you 
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select a part of the image to reset the black point that you don’t click on a rogue 
pixel which doesn’t represent the true sky background of the image. 
   

 
Selecting the Set Black Point  eyedropper 
 

 
Setting the black point to 35,35,35 
 

 
Setting the eyedropper sample size to 5x5 Average 
 
Next, move the eyedropper to a blank area of sky background and left click.  This 
will now set the new black point of the image to 35,35,35. 
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Clicking on blank sky background to set a new black point 

 
Now with that that done, the next step is to check that the sky background is 
neutral and doesn’t have any color cast.  You can check this by simply moving 
the cursor over the sky background and checking if the RGB values are equal 
(i.e. 40,40,40 etc…)  If they are, then this step can be skipped.  If not, the grey 
point will need to be reset. 
 
To do this, with the Levels dialog window still open, click on the Set Grey Point  
eyedropper at the lower right of the window. 
 
Now click on a blank portion of the sky background.  This will reset the grey 
point.  You can check this with the Info palette and make sure the RGB values of 
the sky background are roughly equal. 
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Selecting the Set Grey Point  eyedropper and resetting the grey point 

 
At this point, the black point of the image has been reset to 35,35,35 and the sky 
background has been neutralized.   
 
I did check the white point of the image by checking the pixel values of the 
brightest stars in the image.  The RGB pixel values were very close to 
255,255,255, so resetting the white point of the image wasn’t necessary.   
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Image with black point set to 35,35,35 and sky background neutralized 

 
 
The next step is to continue processing and to use a screen blend to enhance 
the nebulous portions of the image. 
 
The first step of this process is to duplicate the original image. 
 
Choose from the main menu, Image > Duplicate.  
 
Next, use the Dust and Scratches filter to blur the duplicated image.  First, make 
the duplicated image active, and then choose from the main menu, Filter > 
Noise > Dust and Scratches 
 
Set the Threshold  to 0 and move the Radius  slider right until just the nebulous 
portions of the image are visible. I used a value of 21 pixels for this image. 
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Using the Dust & Scratches filter on the duplicated image 

 
Now, Using the method as shown previously, reset the black point of this new 
image.  Instead of setting the black point to 35,35,35 as before, set it now to 
0,0,0.  This will remove some of the extraneous artifacts from the image by 
clipping them to black.  
 
Next, a curves adjustment will be used to bring out the faint nebulosity.  From the 
main  menu, choose Image > Adjustments > Curves. 
 
Create a new point at the center of the curve and drag to the upper left as shown 
on the next page. 
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Bringing out the faint nebulosity with a curves adjustment 

 
With that completed, close the Curves dialog window and choose from the main 
menu, Layer > Duplicate Layer.  
 
In the Duplicate Layer dialog window, change the destination filename to the 
original image.  This will duplicate this image as a new layer called Background 
copy in the original image. 
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Selecting destination document as the original filename 

 
Make the original image active, and you will see there are now two layers.  Make 
the Background copy layer active as shown on the next page. 
 
Next, set the blend mode to Screen. 
 
As you can see, the faint nebulosity has been enhanced and brought out quite 
easily without affecting other portions of the image. 
 
From the main menu, choose Layer > Flatten Image.  
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Original image with the new Background copy layer 

 

 
Make the Background copy layer active, and set blend mode to Screen 
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Next, we will adjust the saturation of the blue portion of the Flaming Star nebula 
using a Curves  adjustment. 
 
 

 
Flaming Star nebula with faint blue nebulosity 

 
To do this, we first need to select the blue portion of the nebula.   
 
From the main menu, choose Select > Color Range  and click on a blue portion 
of the nebula.  Adjust the Fuzziness  slider until just the blue portion is selected.  
Once this is done, click OK.  If other portions of the image were selected, which 
is likely, simply use the freehand Lasso  tool to subtract those areas from the 
current selection. 
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Using the Color Range  tool to select the blue nebulosity 

 
 
On the next page, you can see that just the blue portions of the nebulosity are 
selected. 
 
Next, a curves adjustment will be used to adjust the saturation of the blue 
nebulosity.  From the main  menu, choose Image > Adjustments > Curves. 
 
First change the channel to Blue  and then create a new point at the center of the 
curve and drag to the upper left as shown on the next page. 
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Flaming Star nebula with only blue nebulosity selected 

 

 
Using a Curves  adjustment to enhance the blue nebulosity 
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Once completed, press CTRL-D on the keyboard to deselect the current 
selection. 
 
The final step is to apply a subtle sharpening to the image using the Unsharp 
Mask filter. 
 
From the main menu, choose Filter > Sharpen > Unsharp Mask.  
 

 
Using the Unsharp Mask filter to sharpen the image and bring out the faint stars 

 
Set the Amount  to about 100%, and then slowly increase the Radius  slider until 
the faintest and smallest stars begin to sharpen.  Other portions of the image, 
including the larger stars will sharpen as well, so next is to adjust the Threshold  
slider by moving it to the right.  This will make it so the Unsharp Mask  will not 
affect the larger stars or objects in the image.  I used a Threshold  value of 30 for 
this particular image and a Radius  value of 2.2.  
 
At this point, the image processing is completed.  Save the image. 



 
    ��������	
���
�
��������                                                                           

 
 

December 2006 Rev - - 33 - http://www.DanielMcCauley.com 
��������	
������

 
Final processed image 
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